Hierarchical Network LAB: Design Hierarchical Network and Configure the HSRP with Multiple VLANs, Trunking, STP, EtherChannel, Hybrid Routing Protocols.

Hierarchical Network: Core, Distribution and Access Layer

The Hierarchical Network Model is a structured approach to designing scalable and efficient networks. The design methodology achieves better management, performance, and security by dividing the network into different layers, each with specific functions and responsibilities. It is typically divided into three main layers showing into the below hierarchy diagram.

1. Core Layer (Backbone)

The Core Layer is a high-speed backbone of the network. It Provides fast and reliable transport between distribution layer devices and always connect multiple distribution Layer devices together. It is designed for speed, redundancy, and minimal latency. Also uses high-end switches and routers with high bandwidth. Therefore, in this layer ensuring high-speed backbone, fast and reliable data transfer among of the next layer devices. 

2. Distribution Layer (Aggregation Layer)

By this layer all devices connects with the access layer and the core layer. In a word, Its Act as an intermediary between the Core Layer and the Access Layer, and keeps local traffic confined to local networks. In this layer, Aggregates the traffic from multiple access layer devices before sending it to the core, and

Implements policies, security (firewalls, VLANs, ACLs), facilitates redundancy, load balancing, and Quality of Service (QoS). We may uses Layer 3 switches or routers for inter-VLAN routing.

3. Access Layer (Edge Layer)

Access Layer provides direct connectivity to end-user devices (computers, printers, IoT, etc.). Includes switches, wireless access points (APs), and VoIP devices. Implements security features like port security, authentication (802.1X), and VLAN segmentation. Typically we uses Layer 2 switches with some Layer 3 capabilities


Tier 2 and Tier 3 Network Architecture

Tier Two: A two-tier network topology refers to a network architecture that has two layers, or tiers, of network devices. This architecture is often used in smaller networks, where a more complex three-tier topology is not needed. However, it may not be as scalable as a three-tier topology.

Tier-Three: This architecture allows for a scalable and fault-tolerant network, and it makes it easier to add new devices and services.




In this Scenario, Try to make a diagram for Tier-3 Network and by following procedures - 

Step-1: PAgP/LACP Configuration.

Step-2: STP Convergence and Configuration

Step-3: Multiple VLANs configuration

Step-4: Configure Inter-VLAN & HSRP Configuration between Local Routers (Active-Standby)

Step-5: BGP Routing Configuration between ISP Router to Local Routers and vice versa.

Step-6: OSPF Routing Configuration for the ISP Router.


Diagram: Tier-3 Network Architecture (as demo)























Following configuration Step by Step by using Cisco Packet Tracer - 

Step-1: Configure EtherChannel 

Port Channel Table - 

Channel Group Ports Protocol
1 Dist_100.9(Gi1/0/1 - 2) & Dist_100.10(Gi1/0/1 - 2)PAgP
2Dist_100.9(Gi1/0/3 - 4) & Dist_100.4(Gi1/0/3 - 4)

PAgP 

3 Dist_100.9(Gi1/0/5 - 6) & Dist_100.5(Gi1/0/5 - 6)

PAgP

Channel Group Ports Protocol
4 Dist_100.10(Gi1/0/5 - 6)& Dist_100.4(Gi1/0/5 - 6)
PAgP
5Dist_100.4(Gi1/0/1 - 2) & Dist_100.5(Gi1/0/1 - 2)PAgP
6 Dist_100.5(Gi1/0/3 - 4) & Dist_100.10(Gi1/0/3 - 4)
PAgP

Instructions -

Part 1: Configure Basic Switch Settings

a. Assign each switch a hostname according to the topology diagram.

b. Before beginning the link aggregation between switches, verify the existing configuration of the ports that connect the switches to ensure that the ports will successfully join the EtherChannels. Commands that provide information about the state of the switch ports include:

Switch# show interfaces | include Ethernet

Switch# show interface status

Switch# show interfaces trunk


 c . Configure all ports that are required for the EtherChannels as static trunk ports.

 Part 2: Configure an EtherChannel with Cisco PAgP


    Task 1: Configure Port Channel 1.

    Dist_100.9# show interfaces trunk
    
Dist_100.9(config)# interface range Gi1/0/1 - 2
    
Dist_100.9(config-if-range)# shutdown
    
Dist_100.9(config-if-range)# channel-group 1 mode desirable
    
Dist_100.9(config-if-range)# no shutdown
    Dist_100.9(config)# interface port-channel 1
    
Dist_100.9(config-if)# switchport mode trunk

    Dist_100.10(config)# interface range Gi1/0/1 - 2
    
Dist_100.10(config-if-range)# shutdown
    
Dist_100.10(config-if-range)# channel-group 1 mode desirable
    
Dist_100.10(config-if-range)# no shutdown
    
Dist_100.10(config)# interface port-channel 1
    
Dist_100.10(config-if)# switchport mode trunk

    Task 2: Verify Port Channel 1 status.

    Dist_100.9# show etherchannel summary
    Dist_100.9# show interfaces trunk
    Dist_100.9# show protocols

    Dist_100.10# show etherchannel summary
    Dist_100.10# show interfaces trunk
    DIST-100.9#show interfaces port-channel 1

N:B: Configure all of the Port Channels according to the table for all Switches.


  Step-2: STP Configuration


Part 1: Enable STP

  Dist_100.9# show spanning-tree
  DIST-100.9(config)#spanning-tree mode ?
        pvst              Per-Vlan spanning tree mode
        rapid-pvst      Per-Vlan rapid spanning tree mode
  DIST-100.9(config)#spanning-tree mode rapid-pvst
  DIST-100.9# show spanning-tree active/summary/vlan id/details

Part 2: Configure the Portfast

    DIST-100.9(config)#spanning-tree portfast ?
        bpduguard      Enable portfast bpdu guard on this switch
        default            Enable portfast by default on all access ports
    DIST-100.9(config)#spanning-tree portfast

Part 3: Root Bridge Selection (after creating VLAN)

 DIST-100.9(config)#spanning-tree <vlan id> ?
      priority      Set the bridge priority for the spanning tree
      root          Configure switch as root
      <cr>
 DIST-100.9(config)#spanning-tree <vlan id> priority ?
      <0-61440>  bridge priority in increments of 4096
 DIST-100.9(config)#spanning-tree <vlan id> root ?

        primary      Configure this switch as primary root for this spanning tree

        secondary   Configure switch as secondary root


N:B: Configure the Basic STP for all Switches initially.



Step-3: Multiple VLANs configuration & STP too


Part-1: VLAN Creation according to diagram

DIST-100.9(config)#vlan 100

DIST-100.9(config)#vlan 13

DIST-100.9(config)#vlan 64

DIST-100.9(config)#vlan 128


Part-2: Configure the switchport to trunk port


DIST-100.9(config)#interface range gigabitEthernet 1/0/1 - 6

DIST-100.9(config-if-range)#switchport trunk encapsulation dot1q 

DIST-100.9(config-if-range)#switchport mode trunk

DIST-100.9(config-if-range)#switchport trunk allowed vlan 13, 64, 100, 128

""OR""

DIST-100.9(config-if-range)#switchport trunk native vlan 100



Part-3: STP Priority Set/Root bridge Selection for each switches


DIST-100.9(config)#spanning-tree vlan 13 priority 4096

DIST-100.9(config)#spanning-tree vlan 64 priority 4096

DIST-100.9(config)#spanning-tree vlan 100 priority 4096

DIST-100.9(config)#spanning-tree vlan 128 priority 4096

""OR""

DIST-100.9(config)#spanning-tree vlan 13 root primary


Part-4: Configure Access Switchport as per VLAN in the Access layer


SW1-100.6(config)#vlan 100

SW1-100.6(config)#vlan 13

SW1-100.6(config)#vlan 64

SW1-100.6(config)#vlan 128


SW1-100.6(config)#interface range fastEthernet 0/1 - 2

SW1-100.6(config-if-range)#switchport mode access

SW1-100.6(config-if-range)#switchport access vlan 13

SW1-100.6(config-if-range)#no shutdown


SW1-100.6(config)#interface range fastEthernet 0/3 - 4

SW1-100.6(config-if-range)#switchport mode access

SW1-100.6(config-if-range)#switchport access vlan 64

SW1-100.6(config-if-range)#no shutdown


SW1-100.6(config)#spanning-tree vlan 13 priority 4096

SW1-100.6(config)#spanning-tree vlan 64 priority 4096

SW1-100.6(config)#spanning-tree vlan 100 priority 4096

SW1-100.6(config)#spanning-tree vlan 128 priority 4096


N:B: Above the Procedures have to perform to all of the switches.



Step-4: Configure the Inter-Vlan and HSRP (Active-Standby Mode)


Part-1: Configure the Router as Active Mode


Active_R(config)#interface GigabitEthernet0/0
Active_R(config)#no shutdown

Active_R(config)#interface GigabitEthernet0/0.100
Active_R(config-subif)#encapsulation dot1Q 100

Active_R(config-subif)#ip address 10.10.100.2 255.255.255.224

Active_R(config-subif)#standby 1 ip 10.10.100.1

Active_R(config-subif)#standby 1 priority 110


Active_R(config)#interface GigabitEthernet0/0.13
Active_R(config-subif)#encapsulation dot1Q 13

Active_R(config-subif)#ip address 11.12.13.2 255.255.255.192

Active_R(config-subif)#standby 1 ip 11.12.13.1

Active_R(config-subif)#standby 1 priority 110


Active_R(config)#interface GigabitEthernet0/0.64
Active_R(config-subif)#encapsulation dot1Q 64

Active_R(config-subif)#ip address 11.12.13.66 255.255.255.192

Active_R(config-subif)#standby 1 ip 11.12.13.65

Active_R(config-subif)#standby 1 priority 110


Active_R(config)#interface GigabitEthernet0/0.128
Active_R(config-subif)#encapsulation dot1Q 128

Active_R(config-subif)#ip address 11.12.13.130 255.255.255.192

Active_R(config-subif)#standby 1 ip 11.12.13.129

Active_R(config-subif)#standby 1 priority 110


Part-2: Configure the Router as Standby Mode


Standby_R(config)#interface GigabitEthernet0/0
Standby_R(config)#no shutdown

Standby_R(config)#interface GigabitEthernet0/0.100
Standby_R(config-subif)#encapsulation dot1Q 100

Standby_R(config-subif)#ip address 10.10.100.3 255.255.255.224

Standby_R(config-subif)#standby 1 ip 10.10.100.1

Standby_R(config-subif)#standby 1 priority 90


Standby_R(config)#interface GigabitEthernet0/0.13
Standby_R(config-subif)#encapsulation dot1Q 13

Standby_R(config-subif)#ip address 11.12.13.3 255.255.255.192

Standby_R(config-subif)#standby 1 ip 11.12.13.1

Standby_R(config-subif)#standby 1 priority 90


Standby_R(config)#interface GigabitEthernet0/0.64
Standby_R(config-subif)#encapsulation dot1Q 64

Standby_R(config-subif)#ip address 11.12.13.67 255.255.255.192

Standby_R(config-subif)#standby 1 ip 11.12.13.65

Standby_R(config-subif)#standby 1 priority 90


Standby_R(config)#interface GigabitEthernet0/0.128
Standby_R(config-subif)#encapsulation dot1Q 128

Standby_R(config-subif)#ip address 11.12.13.131 255.255.255.192

Standby_R(config-subif)#standby 1 ip 11.12.13.129

Standby_R(config-subif)#standby 1 priority 90


Part-3: Checked The HSRP and Inter-Vlan


Active_R#show standby brief

Active_R#show running-config


Standby_R#show standby brief

Standby_R#show running-config



Step-5: Configure the BGP and OSPF at the ISP's Router


Part-1: Basic IP Assign to ISP Router


ISP_R(config)#interface Serial0/0/0

ISP_R(config-if)#ip address 1.1.1.1 255.255.255.252

ISP_R(config-if)#no shutdown


ISP_R(config)#interface Serial0/0/1

ISP_R(config-if)#ip address 2.2.2.1 255.255.255.252

ISP_R(config-if)#no shutdown


ISP_R(config)#interface GigabitEthernet0/0

ISP_R(config-if)#ip address 10.10.1.1 255.255.255.252

ISP_R(config-if)#no shutdown


ISP_R(config)#interface GigabitEthernet0/1

ISP_R(config-if)#ip address 8.8.8.1 255.255.255.240

ISP_R(config-if)#no shutdown


Part-2: OSPF Configuration as Diagram


ISP_R(config)#router ospf 10

ISP_R(config-router)#network 10.10.1.0 0.0.0.3 area 10

ISP_R(config-router)#network 8.8.8.0 0.0.0.15 area 10


ISP_R(config)#interface GigabitEthernet0/0

ISP_R(config-if)#ip ospf 10 area 10

ISP_R(config-if)#ip ospf network point-to-point


ISP_R(config)#interface GigabitEthernet0/1

ISP_R(config-if)#ip ospf 10 area 10

ISP_R(config-if)#ip ospf network point-to-point



Part-3: BGP Configuration as Diagram


ISP_R(config)#router bgp 300

ISP_R(config-router)#neighbor 1.1.1.2 remote-as 200
ISP_R(config-router)#neighbor 2.2.2.2 remote-as 100
ISP_R(config-router)#network 1.1.1.0 mask 255.255.255.252
ISP_R(config-router)#network 2.2.2.0 mask 255.255.255.252
ISP_R(config-router)#redistribute ospf 10 match external 1 external 2 


Step-6: BGP Configuration to Local Routers

Part-1: IP Assigned and BGP Configure Active/Standby Routers

Active_R(config)#interface Serial0/0/0

Active_R(config-if)#ip address 1.1.1.2 255.255.255.252

Active_R(config-if)#no shutdown


Active_R(config)#router bgp 200
Active_R(config-router)#neighbor 1.1.1.1 remote-as 300
Active_R(config-router)#network 1.1.1.0 mask 255.255.255.252

Standby_R(config)#interface Serial0/0/1

Standby_R(config-if)#ip address 2.2.2.2 255.255.255.252

Standby_R(config-if)#no shutdown

Standby_R(config)#router bgp 100
Standby_R(config-router)#neighbor 2.2.2.1 remote-as 300
Standby_R(config-router)#network 2.2.2.0 mask 255.255.255.252


Part-2: Checking the BGP and Routing table

Active_R#show ip bgp
Active_R#show ip route
Active_R#show ip bgp summary
Active_R#show ip bgp neighbors

Standby_R#show ip bgp
Standby_R#show ip route
Standby_R#show ip bgp summary
Standby_R#show ip bgp neighbors


Step-07: Finally, Assigned IP all PCs and Servers and Checked all Devices to Ping each other.






STEP-08: DEMO CONFIGURATION IN THE CISCO PACKET TRACER


Popular posts from this blog

CCNA Class 01: Basic Networking & Network Architecture

Summary Of The RHELv9 Book Ref:124 (Theoritical Based)

CCNA Class 04: Work Functionality of the required Network Components & Number System